Simple Queue Otomatis DHCP Server Mikrotik

Salah satu fungsi Mikrotik adalah pembatasan bandwidth untuk klien yang terhubung di ether tertentu. Pembatasan itu bisa menggunakan Simple Queue ataupun Queue Tree tergantung kebutuhan. Untuk memudahkan pekerjaan kita bisa setting Simple Queue Mikrotik agar otomatis muncul saat DHCP Server terjadi bound dari klien.

Script simple Queue ini akan otomatis membuat setting batasan bandwidth sesuai dengan keinginan dan akan terhapus sendirinya saat DHCP lease time sudah habis. Tentunya ini akan lebih efektif daripada kita membuat simple Queue satu-satu.

Cara Membuat Simple Queue Otomatis

Untuk membuat simple queue bekerja otomatis di Mikrotik kita maka kita perlu melakukan sedikit setting. Berikut ini langkah-langkahnya.

  1. Membuat parent queue agar nantinya child bisa otomatis mengikuti besaran batasan bandwidth utama.
  2. Langkah selanjutnya pasang Script ini pada profil DHCP server yang akan menjadi target.
    :local queueName "Client-$leaseActMAC";
    :if ($leaseBound = "1") do={
    /queue simple add name=$queueName target=($leaseActIP . "/32") limit-at=1M/2M max-limit=1M/2M parent=Lokal;
    } else={
    /queue simple remove $queueName
    }
  3. Uji dengan perangkat seperti laptop maupun handphone. Nantinya akan muncul satu Simple Queue dengan MAC address perangkat.

Bagikan ke Temanmu

Copyright © 2021 - JP.com
Whatsapp Jepe